Post a reply
Username:
Note:If not registered, provide any username. For more comfort, register here.
Subject:
Message body:
Enter your message here, it may contain no more than 60000 characters. 

Smilies
:D :) :( :o :shock: :? 8) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :wink: :!: :?: :idea: :arrow: :| :mrgreen:
Font size:
Font colour
Options:
BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON
Disable BBCode
Disable smilies
Do not automatically parse URLs
Confirmation of post
To prevent automated posts the board requires you to enter a confirmation code. The code is displayed in the image you should see below. If you are visually impaired or cannot otherwise read this code please contact the %sBoard Administrator%s.
Confirmation code:
Enter the code exactly as it appears. All letters are case insensitive, there is no zero.
   

Topic review - Problems installing...help!
Author Message
  Post subject:  Re: Problems installing...help!  Reply with quote
- Solution for dynamic module:
Singular uses dynamic modules at 2 places:
* for polynomial operations
but there is a variant without dynamic modules
the configure options
Code:
--disable-p-procs-dynamic --enable-p-procs-static

should select this variant (configure should automatically select this on Windows)
* for optional pacakages
can be embedded via
Code:
----with-builtinmodules=a,b,c

Technical background: dynamic modules are shared libarires with unresolved
symbols from the Singular kernel. The dynamic linker on ELF systems
(and on HPUX) resolves theese references automatically during the loading.
AFAIK the dynamic linker on Windows cannot do this, so dynamic modules
(at least currently) cannot work on Windows, but work-arounds exists - see above.
Post Posted: Tue May 05, 2015 1:21 pm
  Post subject:  Re: Problems installing...help!  Reply with quote
Javo wrote:
I have exactly the same problem. Some one can help us, please.


I and Yue are working on the updated cygwin package for 32 and 64 bit version
https://cygwin.com/ml/cygwin-apps/2015-04/msg00035.html

We should upload in 1-2 weeks.

Regards
Marco
Post Posted: Tue May 05, 2015 6:04 am
  Post subject:  Re: Problems installing...help!  Reply with quote
2 remarks:
- currently only the binary for 32bit cygwin exists, that means it will not work in a 64bit
cygwin environment
- Singular uses the following dynamic libraries, but they all belong to the default
cygwin installation (or the system):
ntdll.dll => /cygdrive/c/Windows/SYSTEM32/ntdll.dll (0x77ad0000)
kernel32.dll => /cygdrive/c/Windows/system32/kernel32.dll (0x761f0000)
KERNELBASE.dll => /cygdrive/c/Windows/system32/KERNELBASE.dll (0x75e90000)
cygwin1.dll => /usr/bin/cygwin1.dll (0x61000000)
cygreadline7.dll => /usr/bin/cygreadline7.dll (0x6f880000)
cygncursesw-10.dll => /usr/bin/cygncursesw-10.dll (0x6f9a0000)
USER32.dll => /cygdrive/c/Windows/system32/USER32.dll (0x77720000)
GDI32.dll => /cygdrive/c/Windows/system32/GDI32.dll (0x77570000)
LPK.dll => /cygdrive/c/Windows/system32/LPK.dll (0x774e0000)
USP10.dll => /cygdrive/c/Windows/system32/USP10.dll (0x77c80000)
msvcrt.dll => /cygdrive/c/Windows/system32/msvcrt.dll (0x77430000)
cyggcc_s-1.dll => /usr/bin/cyggcc_s-1.dll (0x6fd20000)
cygstdc++-6.dll => /usr/bin/cygstdc++-6.dll (0x6f6e0000)
cyggmp-10.dll => /usr/bin/cyggmp-10.dll (0x6fc70000)
cygmpfr-4.dll => /usr/bin/cygmpfr-4.dll (0x6fa20000)
IMM32.DLL => /cygdrive/c/Windows/system32/IMM32.DLL (0x76090000)
MSCTF.dll => /cygdrive/c/Windows/system32/MSCTF.dll (0x77230000)

I.e. make sure that you have readline, gmp, mpfr and ncurses installed.

Use (and missing shared libraries) can be found with:
ldd /usr/bin/Singular.exe
Post Posted: Wed Apr 15, 2015 1:25 pm
  Post subject:  Re: Problems installing...help!  Reply with quote
I have exactly the same problem. Some one can help us, please.
Post Posted: Tue Apr 14, 2015 6:55 pm
  Post subject:  Re: Problems installing...help!  Reply with quote
Was able to install with 32-bit, but can't start Singular from Cygwin.
Post Posted: Fri Apr 10, 2015 6:19 am
  Post subject:  Problems installing...help!  Reply with quote
Hi there,

Every time I try to connect to ftp.uni-kl.de with the Cygwin install as per the instructions, I get a message which says that setup.ini can't be found, and then when a package repository is listed, Singular isn't in it. I am running 64-bit Windows and I've already installed Cygwin. Thanks!
Post Posted: Fri Apr 10, 2015 5:45 am


It is currently Thu Dec 14, 2017 7:11 pm
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group