Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: Error in using HilberClassPoly command
PostPosted: Thu Jun 23, 2016 6:49 pm 

Joined: Sat Apr 16, 2016 7:25 pm
Posts: 8
Even if I run the example given in manual for HilberClassPoly from atkins.lib, I get following error,

> ring r = 0,x,dp;
> number D=-23;
> HilbertClassPoly (D,50);
? `bigint`(D) = `number` is not supported
? expected `bigint` = `bigint`
? error occurred in or before atkins.lib::HilbertClassPoly line 524: `parameter bigint D; parameter int k;
? leaving atkins.lib::HilbertClassPoly
skipping text from `;` error at token `)`

Version Details:
Development version 4.0.2
Feb 2015

Though I can do specify it directly,
> HilbertClassPoly (-23,50);
x3+3491750x2-5151296875x+12771880859375

Can someone please make necessary changes in manual please?


Report this post
Top
 Profile  
Reply with quote  
 Post subject: Re: Error in using HilberClassPoly command
PostPosted: Fri Jun 24, 2016 10:12 am 

Joined: Wed May 25, 2005 4:16 pm
Posts: 177
D must be of type bigint (or int), and the manual tells this:
Code:
LIB "atkins.lib";
ring r = 0,x,dp;
bigint D=-23;
HilbertClassPoly(D,50);
==> x3+3491750x2-5151296875x+12771880859375


Report this post
Top
 Profile  
Reply with quote  
 Post subject: Re: Error in using HilberClassPoly command
PostPosted: Fri Jun 24, 2016 11:51 am 

Joined: Sat Apr 16, 2016 7:25 pm
Posts: 8
I checked that the manual I was using is version 3-1-1, Feb 2010 and its older version.
In newer version it is bigint.

Thanks for replying.


Report this post
Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

You can post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

It is currently Sun Oct 22, 2017 3:55 pm
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group