Singular
http://www.singular.uni-kl.de/forum/

Error in using HilberClassPoly command
http://www.singular.uni-kl.de/forum/viewtopic.php?f=10&t=2543
Page 1 of 1

Author:  pankajsejwal [ Thu Jun 23, 2016 6:49 pm ]
Post subject:  Error in using HilberClassPoly command

Even if I run the example given in manual for HilberClassPoly from atkins.lib, I get following error,

> ring r = 0,x,dp;
> number D=-23;
> HilbertClassPoly (D,50);
? `bigint`(D) = `number` is not supported
? expected `bigint` = `bigint`
? error occurred in or before atkins.lib::HilbertClassPoly line 524: `parameter bigint D; parameter int k;
? leaving atkins.lib::HilbertClassPoly
skipping text from `;` error at token `)`

Version Details:
Development version 4.0.2
Feb 2015

Though I can do specify it directly,
> HilbertClassPoly (-23,50);
x3+3491750x2-5151296875x+12771880859375

Can someone please make necessary changes in manual please?

Author:  hannes [ Fri Jun 24, 2016 10:12 am ]
Post subject:  Re: Error in using HilberClassPoly command

D must be of type bigint (or int), and the manual tells this:
Code:
LIB "atkins.lib";
ring r = 0,x,dp;
bigint D=-23;
HilbertClassPoly(D,50);
==> x3+3491750x2-5151296875x+12771880859375

Author:  pankajsejwal [ Fri Jun 24, 2016 11:51 am ]
Post subject:  Re: Error in using HilberClassPoly command

I checked that the manual I was using is version 3-1-1, Feb 2010 and its older version.
In newer version it is bigint.

Thanks for replying.

Page 1 of 1 All times are UTC + 1 hour [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/