Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: cannot open singular on a running emacs
PostPosted: Thu Feb 04, 2016 5:51 pm 

Joined: Sun Jan 31, 2016 9:15 am
Posts: 2
I am a newbies in Singular. I just downloaded Singular4-0-2_64.dmg, mounted the image, right-ckick, show the package contents, then moved the contents folder to the Applications directory. double-clicking Contents/MacOS/Singular (or Esingular) I have Singular running in a terminal (or via emacs in a terminal). But when I try M-x singular in a running emacs, it says "cannot open load file : no such file or directory, singular". Have I installed Singular properly? I appreciate your help.

Also I must mention that I am a user of emacs for Macaulay2. For that I have changed .emacs and .emacs-Macaulay2 in order to teach emacs where to look for M2. Is there anything similar to be done for Singular? Shall I have a file .emacs-singular somewhere?

Thanks for your help.


Report this post
Top
 Profile  
Reply with quote  
 Post subject: Re: cannot open singular on a running emacs
PostPosted: Fri Feb 05, 2016 4:25 am 

Joined: Sat Oct 01, 2005 11:40 am
Posts: 35
Location: IIT Guwahati, Guwahati, Assam, INDIA
You can put the following code in your .emacs
Code:
(setq load-path (cons "<singular-emacs-home-directory>" load-path))
(autoload 'singular "singular"
  "Start Singular using default values." t)
(autoload 'singular-other "singular"
  "Ask for arguments and start Singular." t)


You can find more details here: http://www.singular.uni-kl.de/Manual/latest/sing_23.htm

-- VInay


Report this post
Top
 Profile  
Reply with quote  
 Post subject: Re: cannot open singular on a running emacs
PostPosted: Sat Feb 06, 2016 11:01 am 

Joined: Sun Jan 31, 2016 9:15 am
Posts: 2
Thanks. I copied that lisp code to ~/.emacs, changing singular-emacs-home-directory into /Applications/Singular.app/Contents/share/singular/emacs/
But still it doesn't work.
I also copied /Applications/Singular.app/Contents/share/singular/emacs/.emcs-singular to the home directory, changed singular-emacs-home-directory into the above directory whereever it was mentioned and replaced it with .emacs as it is suggested in .emacs-singular. But they I get the error: "Warning (initialization): An error occurred while loading `/Users/Me/.emacs':

Symbol's value as variable is void: /Applications/Singular.app/Contents/share/singular/emacs"

here is the file .emacs:

;; Macaulay 2 start
(load "~/.emacs-Macaulay2" t)
;; Macaulay 2 end

(setq M2-exe "/Applications/Macaulay2-1.6/bin/M2")

(custom-set-variables
;; custom-set-variables was added by Custom.
;; If you edit it by hand, you could mess it up, so be careful.
;; Your init file should contain only one such instance.
;; If there is more than one, they won't work right.
'(frame-resize-pixelwise t))
(custom-set-faces
;; custom-set-faces was added by Custom.
;; If you edit it by hand, you could mess it up, so be careful.
;; Your init file should contain only one such instance.
;; If there is more than one, they won't work right.
)

(setq load-path (cons "</Applications/Singular.app/Contents/share/singular/emacs/>" load-path))
(autoload 'singular "singular"
"Start Singular using default values." t)
(autoload 'singular-other "singular"
"Ask for arguments and start Singular." t)

(load-file "~/.emacs-general")


Report this post
Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

You can post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

It is currently Sun Dec 17, 2017 10:05 am
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group