Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#117 closed bug (fixed)

BUG in SCA: sca( GB, new_poly )

Reported by: Oleksandr Owned by: Oleksandr
Priority: major Milestone: 3-1-1
Component: singular-kernel Version:
Keywords: SCA, std, bba Cc:

Description

the result of std(std(0), xy + z) is wrong in an exterior algebra (in variables: x,y,z).

seems to be due to special implementation of bba in SCA.

Attachments (3)

sca_std_1.tst (778 bytes) - added by Oleksandr 14 years ago.
my tests
sca_std_1.tst.log (9.3 KB) - added by Oleksandr 14 years ago.
my results for the test. (bug only in Exterior algebra... not in a factor algebra!)
sca_std_1_vl.res (3.8 KB) - added by Oleksandr 14 years ago.
same test without SCA

Download all attachments as: .zip

Change History (8)

Changed 14 years ago by Oleksandr

Attachment: sca_std_1.tst added

my tests

Changed 14 years ago by Oleksandr

Attachment: sca_std_1.tst.log added

my results for the test. (bug only in Exterior algebra... not in a factor algebra!)

comment:1 Changed 14 years ago by Oleksandr

The problem is that {xy + z} is not a GB there...

Changed 14 years ago by Oleksandr

Attachment: sca_std_1_vl.res added

same test without SCA

comment:2 Changed 14 years ago by Oleksandr

Well, without SCA - no bug, which means this is purely SCA bug.

comment:3 Changed 14 years ago by Oleksandr

Keywords: bba added

primary entry point is jjSTD_1. further calls: -> kStd -> nc_GB.

Main difference is due to: int strat->newIdeal (position of additional poly/vector in F) It seems that it will be handled transparently by initBuchMora and other shadow procedures backing bba...

Hmm... what does TEST_OPT_SB_1 mean?

comment:4 Changed 14 years ago by Oleksandr

Resolution: fixed
Status: newclosed

this was quite a deal... have found a bug in enterSSpecialPairs (clearS was disabled for non-commutative rings). seems to work now... would be nice to test.

comment:5 Changed 14 years ago by seelisch

Milestone: Releases 3-1-1 and higher
Note: See TracTickets for help on using tickets.