Opened 14 years ago

Closed 13 years ago

#119 closed bug (fixed)

BUG in mres

Reported by: Oleksandr Owned by: hannes
Priority: major Milestone: 3-1-1
Component: singular-kernel Version:
Keywords: mres Cc: levandov

Description

There seems to be a bug in mres (for certain GR-algebras) - i have got a Segmentation fault. See test/log.

Attachments (4)

mres_vl.tst (558 bytes) - added by Oleksandr 14 years ago.
tests
mres_vl.tst.log (4.6 KB) - added by Oleksandr 14 years ago.
my log with Segmentation fault
mres_vl.log (4.7 KB) - added by Oleksandr 14 years ago.
same bug in commutative qring!
mres_vl.2.tst (735 bytes) - added by Oleksandr 14 years ago.
same test (in commutative setting)

Download all attachments as: .zip

Change History (9)

Changed 14 years ago by Oleksandr

Attachment: mres_vl.tst added

tests

Changed 14 years ago by Oleksandr

Attachment: mres_vl.tst.log added

my log with Segmentation fault

comment:1 Changed 14 years ago by Oleksandr

Component: ALLsingular-kernel

comment:2 Changed 14 years ago by levandov

Is there a real need to investigate marginal exotic cases like the resolution of the ideal, which is zero in the qring? Mres minimizes the resolution, which is not standardized yet. If one activates normal form modulo ideal of qring internally, one gets zero at the very beginning and that's all.

comment:3 Changed 14 years ago by Oleksandr

Cc: levandov added
Keywords: Plural removed
Owner: changed from Oleksandr to hannes
Summary: BUG in mres (PLURAL)BUG in mres

2Viktor: yep. as you probably know this has something to do with good programming practices.

Moreover, this seems to be a minimization issue in factor rings (also present in commutative rings, see new test log) and has nothing to do with non-commutative rings.

Changed 14 years ago by Oleksandr

Attachment: mres_vl.log added

same bug in commutative qring!

Changed 14 years ago by Oleksandr

Attachment: mres_vl.2.tst added

same test (in commutative setting)

comment:4 Changed 14 years ago by seelisch

Milestone: Releases 3-1-1 and higher

comment:5 Changed 13 years ago by hannes

Resolution: fixed
Status: newclosed

seems to be fixed - not reproducible with current version.

Note: See TracTickets for help on using tickets.