Opened 14 years ago

Closed 10 years ago

#212 closed bug (invalid)

wrong computation of genus / error when calling genus

Reported by: Martin Albrecht <malb@… Owned by: slaplagn@…
Priority: minor Milestone: 3-1-1
Component: singular-libs Version: 3-1-1
Keywords: genus Cc:

Description

Martin Albrecht <malb@…>:

Hi,

the following output is wrong in 3-1-1-0 and was correct in the previous version:

ring r = 7,(x,y),dp; LIB("normal.lib"); ideal i = x10 + x3 + y2; genus(i);

32 should be 0

Change History (9)

comment:1 Changed 14 years ago by seelisch

Summary: wrong computation of genuswrong computation of genus / error when calling genus

Here's another bug related to genus:

ring r = 5,(x,y,z),dp;

ideal i = -x3 + y2*z - 2*x*z2 + y*z2; LIB("normal.lib"); genus(i);

? ideal defines not a curve ? leaving normal.lib::genus

comment:2 Changed 14 years ago by seelisch

concerning "Here's another bug related to genus" Gert-Martin Greuel wrote:

"this is not a bug, since Singular computes only the genus for ideals defining a curve (also said in the help for genus) Your ideal defines a surface and therefore the genus cannot be computed (in fact it is not even well defined)."

comment:3 Changed 14 years ago by seelisch

Owner: changed from somebody to slaplagn@…

comment:4 Changed 14 years ago by seelisch

Hi Santiago, in the last SINGULAR meeting (24 March) we decided to redirect this ticket to you. I hope you can do something about the issue. Wolfram and Gert-Martin both asked what the term "genus" in this example should actually mean. Maybe that's the starting point.

Hans suspects that we get a different result with SINGULAR 3-1-1 (than with 3-1-0) because of the changes in normal.lib, especially for positive char.

Regards, Frank

comment:5 Changed 11 years ago by hannes

Resolution: fixed
Status: newclosed

comment:6 Changed 10 years ago by kroeker@…

Resolution: fixed
Status: closedreopened

It is very likely that a corresponding regression test is missing

(I looked for genus calls in ALL test examples)

comment:7 Changed 10 years ago by hannes

Resolution: invalid
Status: reopenedclosed

stop reporting rubbish.see Tst/Manual?/genus.tsta for the test you did not find.

comment:8 Changed 10 years ago by kroeker@…

Resolution: invalid
Status: closedreopened

stop reporting rubbish.see Tst/Manual??/genus.tsta for the test you did not find.

In the second ticket post an issue with the "not a curve"-check is described(see ticket history). Now if that check will be screwed up by future changes, this will be not be detected by current regression tests.

Simulating broken curve check in genus():

--- normal.orig.lib	2014-03-31 12:05:04.339213110 +0200
+++ normal.lib	2014-03-31 12:05:32.924846209 +0200
@@ -2191,6 +2191,7 @@ EXAMPLE: example genus; shows an example
      I=std(I);
      if(dim(I)!=1)
      {
+       ERROR("This is not a curve");
        if(((homog(I))&&(dim(I)!=2))||(!homog(I)))
        {
          ERROR("This is not a curve");

The Tst/Manual/genus.tst will still pass:

>LIB("normal.lib");
> ring r=0,(x,y),dp;
> ideal i=y^9 - x^2*(x - 1)^9;
> genus(i);
0
> ring r7=7,(x,y),dp;
> ideal i=y^9 - x^2*(x - 1)^9;
> genus(i);
0

but the example by Frank Seelisch (see ticket history) will detect the bug:

LIB("normal.lib");
ring r = 5,(x,y,z),dp;
ideal i = -x3 + y2*z - 2*x*z2 + y*z2;
genus(i);

output:

> ring r = 5,(x,y,z),dp;
> ideal i = -x3 + y2*z - 2*x*z2 + y*z2;
> genus(i);
   ? This is not a curve
   ? leaving normal.lib::genus

My report was not rubbish.

comment:9 Changed 10 years ago by hannes

Resolution: invalid
Status: reopenedclosed

this may or may not be a bug (just not looking into it), but it definitely has nothing to do with ticket 212: genus of curves in prime characteristic returns a wrong value. (see http://www.singular.uni-kl.de:8002, first point)

Note: See TracTickets for help on using tickets.