Opened 12 years ago

Closed 11 years ago

#464 closed bug (fixed)

problems with command line option -c

Reported by: semmel.michael@… Owned by: hannes
Priority: major Milestone: 3-1-6 and higher
Component: dontKnow Version: 3-1-5
Keywords: command line options Cc:

Description

I use the command line option "-c" to script Singular for multithreadding using python, when I run the example from the manual I get the following error:

Singular -c "help all.lib; quit;"

SINGULAR /

A Computer Algebra System for Polynomial Computations / version 3-1-5

0<

by: W. Decker, G.-M. Greuel, G. Pfister, H. Schoenemann \ Jul 2012

FB Mathematik der Universitaet, D-67653 Kaiserslautern \ Can not open quit; Can not open all.lib; Singular : signal 11 (v: 3150): current line:>>;return();<< Segment fault/Bus error occurred at 7f7e03506270 because of 10246 (r:1354304812) please inform the authors trying to restart... Can not open quit; Can not open all.lib; Speicherzugriffsfehler

I wrote a Singular program that has to be run several 100 000 times with a different input that is given by a list of integers that is very important for my research, it worked in the older Singular versions but not in the actual on. It would be great if you could help me.

best regards,

Michael Semmel

Change History (5)

comment:1 Changed 12 years ago by steenpass

Which version of Singular exactly do you use (Linux / Windows / Mac, official release binary or source code that you compiled yourself ...)? I tested the command with the latest Singular nightly build and it works.

If you want to run several commands in Singular which are independent of each other, you can also consider to use Singular's parallel.lib, see

http://www.singular.uni-kl.de/Manual/latest/sing_1953.htm

I can assist you if you need any help to get your code running with parallel.lib, and I would also be interested in feedback about this library because it is still a relatively new feature.

comment:2 Changed 12 years ago by anonymous

Thank you Andreas,

I guess parallelWaitAll is exactly the procedure I need. My Singular version is 3-1-5, does parallel.lib use MP links? My server has 128gb memory and so I have to use the 64 bit version. If I run the servers as localhost are they run in the same directory as the master process, because I have to read and write files during each run. How do I control the number of threads that are run at the same time, or do I have to chose the size of the list in a proper way? Do you know by heart how I can make a directory in the directory Singular is running to write output in this new directory. I have to sort my output in a way since I produce several million files.

best regards,

Michael

comment:3 Changed 12 years ago by steenpass

I continued the discussion about parallel.lib via e-mail because it is not related to the bug reported here which should nevertheless be fixed if it still occurs.

comment:4 Changed 11 years ago by boehm

Owner: changed from somebody to hannes

comment:5 Changed 11 years ago by hannes

Resolution: fixed
Status: newclosed

cannot be reproduced with 3-1-6

Note: See TracTickets for help on using tickets.