Opened 16 years ago

Closed 15 years ago

Last modified 15 years ago

#48 closed bug (fixed)

Unexpected behaviour during repeated application of lift over Z.

Reported by: dreyer Owned by: somebody
Priority: minor Milestone: Release 3-1-0
Component: dontKnow Version:
Keywords: Cc: anne@…, singular-team@…

Description

Anne Frühbis-Krüger detected a unexpected behaviour during computations over Z. (Despite the fact, that only std and arithemtic are officially supported, fixing that bug might be interesting anyway.)

                     SINGULAR                             /
  A Computer Algebra System for Polynomial Computations   /   version 3-1-0
                                                        0<
      by: G.-M. Greuel, G. Pfister, H. Schoenemann        \   Aug 2008
FB Mathematik der Universitaet, D-67653 Kaiserslautern    \
> ring r=3Dinteger,(u(1..4),v(12),v(13),v(14),v(23),v(24),v(34)),dp;
// ** You are using coefficients rings which are not fields.
// ** Please note that only limited functionality is available
// ** for these coefficients.
// **
// ** The following commands are meant to work:
// ** - basic polynomial arithmetic
// ** - std
// ** - reduce
> ideal J;
> J[1]=3Du(1);
> J[2]=3Du(4);
> J[3]=3Du(1)+u(3)-v(13);
> J[4]=3Du(1)+u(4)-v(14);
> J[5]=3Du(2)+u(4)-v(24);
> J[6]=3Du(3)+u(4)-v(34);
> J[7]=3Du(1)+u(2)+u(3)+v(12)-v(13)-v(23);
> J[8]=3Du(1)+u(2)+u(4)+v(12)-v(14)-v(24);
> J[9]=3Du(1)+u(2)+u(3)+u(4)+v(12)-v(13)-v(14)-v(23)-v(24)+v(34);
> J[10]=3Dv(24);
> lift(J,maxideal(1));
....funktioniert
> lift(J,maxideal(1));
....funktioniert ein zweites Mal
> lift(J,maxideal(1));
Singular : signal 11 (v: 3100/2008111315):
Segment fault/Bus error occurred at 81891a7 because of 1 (r:1228835114)
please inform the authors
trying to restart...
> lift(J,maxideal(1));
Speicherzugriffsfehler

Change History (5)

comment:1 Changed 16 years ago by dreyer

Cc: singular@… added

comment:2 Changed 16 years ago by dreyer

Summary: Unexpected behaviour during repeated applicatio n of lift over Z.Unexpected behaviour during repeated application of lift over Z.

comment:3 Changed 16 years ago by dreyer

Cc: singular-team@… added; singular@… removed

comment:4 Changed 15 years ago by hannes

Resolution: fixed
Status: newclosed

ring dependend data for these rings are not correctly copied (-> memory corruption after ring changes to/from automatically created rings)

comment:5 Changed 15 years ago by seelisch

Milestone: Release 3-1-0
Note: See TracTickets for help on using tickets.