Opened 10 years ago

Closed 10 years ago

#582 closed bug (not a bug)

Error while compiling spielwiese (commit 8968c1705d)

Reported by: barakat Owned by: hannes
Priority: major Milestone: 4-1-0 and higher
Component: factory Version: 3-1-6
Keywords: Hensel, make, build system Cc:

Description (last modified by Oleksandr )

I get this error early during compiling spielwiese (commit 8968c1705d) on my Mac:

/Applications/Xcode.app/Contents/Developer/usr/bin/make  all-recursive
Making all in resources
/Applications/Xcode.app/Contents/Developer/usr/bin/make  all-am
  CC     omFindExec.lo
  CXX    feResource.lo
  CXX    feFopen.lo
  CXXLD  libresources.la
Making all in omalloc
  CC     omTables-omTables.o
  CCLD   omTables
./omTables > omTables.xx && mv omTables.xx  omTables.inc
./omTables 1 >omTables.yy && mv omTables.yy omTables.h
/Applications/Xcode.app/Contents/Developer/usr/bin/make  all-am
  CC     libomalloc_la-omBinPage.lo
  CC     libomalloc_la-omList.lo
  CC     libomalloc_la-omAllocEmulate.lo
  CC     libomalloc_la-omDebug.lo
  CC     libomalloc_la-om_Alloc.lo
  CC     libomalloc_la-omDebugCheck.lo
  CC     libomalloc_la-omOpts.lo
  CC     libomalloc_la-omGetBackTrace.lo
  CC     libomalloc_la-omAllocSystem.lo
omAllocSystem.c:94:10: warning: implicit declaration of function 'malloc_size' is invalid in C99
      [-Wimplicit-function-declaration]
  return _omSizeOfLargeAddr((char *)addr);
         ^
omAllocSystem.c:32:35: note: expanded from macro '_omSizeOfLargeAddr'
#define _omSizeOfLargeAddr(addr) (OM_MALLOC_SIZEOF_ADDR(addr) & (~SIZEOF_OM_ALIGNMENT_1))
                                  ^
./../omalloc/omMallocSystem.h:17:39: note: expanded from macro 'OM_MALLOC_SIZEOF_ADDR'
#define OM_MALLOC_SIZEOF_ADDR(addr)  (malloc_size(addr))
                                      ^
omAllocSystem.c:212:54: warning: 'sbrk' is deprecated [-Wdeprecated-declarations]
    if (! om_SbrkInit) om_SbrkInit = (unsigned long) sbrk(0) - size;
                                                     ^
/usr/include/unistd.h:582:7: note: 'sbrk' declared here
void    *sbrk(int);
         ^
omAllocSystem.c:219:46: warning: 'sbrk' is deprecated [-Wdeprecated-declarations]
      om_Info.MaxBytesSbrk = (unsigned long) sbrk(0) - om_SbrkInit;
                                             ^
/usr/include/unistd.h:582:7: note: 'sbrk' declared here
void    *sbrk(int);
         ^
omAllocSystem.c:277:46: warning: 'sbrk' is deprecated [-Wdeprecated-declarations]
      om_Info.MaxBytesSbrk = (unsigned long) sbrk(0) - om_SbrkInit;
                                             ^
/usr/include/unistd.h:582:7: note: 'sbrk' declared here
void    *sbrk(int);
         ^
  CC     libomalloc_la-omError.lo
4 warnings generated.
  CC     libomalloc_la-omStats.lo
  CC     libomalloc_la-omRet2Info.lo
omStats.c:20:33: warning: 'sbrk' is deprecated [-Wdeprecated-declarations]
  om_SbrkInit = (unsigned long) sbrk(0);
                                ^
/usr/include/unistd.h:582:7: note: 'sbrk' declared here
void    *sbrk(int);
         ^
omStats.c:65:48: warning: 'sbrk' is deprecated [-Wdeprecated-declarations]
    om_Info.CurrentBytesSbrk = (unsigned long) sbrk(0) - om_SbrkInit;
                                               ^
/usr/include/unistd.h:582:7: note: 'sbrk' declared here
void    *sbrk(int);
         ^
omStats.c:71:35: warning: 'sbrk' is deprecated [-Wdeprecated-declarations]
    om_SbrkInit = (unsigned long) sbrk(0);
                                  ^
/usr/include/unistd.h:582:7: note: 'sbrk' declared here
void    *sbrk(int);
         ^
3 warnings generated.
  CC     libomalloc_la-omBin.lo
  CC     libomalloc_la-omDebugTrack.lo
  CC     libomalloc_la-omalloc_provide.lo
  CC     libomalloc_la-omAllocFunc.lo
  CCLD   libomalloc.la
/Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/ranlib: file: .libs/libomalloc.a(libomalloc_la-omAllocEmulate.o) has no symbols
/Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/ranlib: file: .libs/libomalloc.a(libomalloc_la-omalloc_provide.o) has no symbols
/Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/ranlib: file: .libs/libomalloc.a(libomalloc_la-omAllocEmulate.o) has no symbols
/Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/ranlib: file: .libs/libomalloc.a(libomalloc_la-omalloc_provide.o) has no symbols
Making all in xalloc
  CC     dummy.lo
  CCLD   libomalloc.la
Making all in factory
./bin/makeheader factory.template factory.h
  CXX    cplusplus.o
./bin/makeheader factoryconf.template factoryconf.h
cp factoryconf.h include/factory/
  CXXLD  cplusplus
./cplusplus  >cplusplus.h
cp cplusplus.h include/factory/
cp factory.h include/factory/
/Applications/Xcode.app/Contents/Developer/usr/bin/make  all-recursive
Making all in include/factory
make[4]: Nothing to be done for `all'.
Making all in libfac
  CXX    factor/Factor.lo
  CXX    factor/SqrFree.lo
  CXX    factor/MVMultiHensel.lo
  CXX    factor/Truefactor.lo
  CXX    factor/helpstuff.lo
  CXX    factor/homogfactor.lo
  CC     factor/version.lo
  CXX    factor/tmpl_inst.lo
  CXX    charset/csutil.lo
  CXX    charset/charset.lo
  CXX    charset/reorder.lo
  CXX    charset/alg_factor.lo
  CXX    charset/algfactor.lo
  CXXLD  libfac.la
  CXX    canonicalform.lo
  CXX    algext.lo
  CXX    cf_algorithm.lo
  CXX    cf_binom.lo
  CXX    cf_char.lo
  CXX    cf_chinese.lo
  CXX    cf_cyclo.lo
  CXX    cf_eval.lo
  CXX    cf_factor.lo
  CXX    cf_factory.lo
  CXX    cf_gcd.lo
  CXX    cf_gcd_smallp.lo
  CXX    cf_generator.lo
  CXX    cf_globals.lo
  CXX    cf_hnf.lo
  CXX    cf_inline.lo
  CXX    cf_irred.lo
  CXX    cf_iter.lo
  CXX    cf_iter_inline.lo
  CXX    cf_linsys.lo
  CXX    cf_map.lo
  CXX    cf_map_ext.lo
  CXX    cfNewtonPolygon.lo
  CXX    cfModResultant.lo
  CXX    cf_ops.lo
  CXX    cf_primes.lo
  CXX    cf_random.lo
  CXX    cf_resultant.lo
  CXX    cf_reval.lo
  CXX    cf_switches.lo
  CXX    cf_util.lo
  CXX    debug.lo
  CXX    DegreePattern.lo
  CXX    ExtensionInfo.lo
  CXX    facAbsBiFact.lo
  CXX    facAbsFact.lo
  CXX    facAlgExt.lo
  CXX    facBivar.lo
  CXX    fac_berlekamp.lo
  CXX    fac_cantzass.lo
  CXX    fac_distrib.lo
fac_distrib.cc:183:12: error: use of undeclared identifier 'Hensel'
    return Hensel( U * power( l, n-1 ), G, lcG, A, bound, x );
           ^
fac_distrib.cc:212:12: error: use of undeclared identifier 'Hensel'
    return Hensel(U, G, TrueLcs, A, bound, x);
           ^
2 errors generated.
make[4]: *** [fac_distrib.lo] Error 1
make[4]: *** Waiting for unfinished jobs....
make[3]: *** [all-recursive] Error 1
make[2]: *** [all] Error 2
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Change History (4)

comment:1 Changed 10 years ago by Oleksandr

Component: dontKnowfactory
Description: modified (diff)
Keywords: Hensel make build system added
Owner: changed from somebody to hannes

comment:2 Changed 10 years ago by Oleksandr

hmm... works under Linux and on my old Macbook...

did you change anything (like XCode etc) on your Mac recently?

which compiler are you using?

Last edited 10 years ago by Oleksandr (previous) (diff)

comment:3 Changed 10 years ago by barakat

I use the clang compiler

comment:4 Changed 10 years ago by hannes

Resolution: not a bug
Status: newclosed

your factory/Makefile is out of date (fac_distrib.cc should not be compiled,it is kept only for reference), run ./autogen.sh

Note: See TracTickets for help on using tickets.