Opened 10 years ago

Closed 10 years ago

#588 closed bug (fixed)

attrib "isSB" not set by quotient() despite option(returnSB)

Reported by: steenpass Owned by: somebody
Priority: minor Milestone: 3-2-0 and higher
Component: dontKnow Version: 3-1-7
Keywords: quotient, isSB Cc:

Description

steenpas@wawa:~$ Singular-n -v
Singular for x86_64-Linux version 3-1-7 (3170)  Mar 20 2014 06:18:01
with
	factory(@(#) factoryVersion = 3.1.7),libfac(3.1.7,December 2013),
	GMP(5.1),NTL(5.5.2),64bit,static readline,Plural,fan/cone,DBM,
	dynamic modules,dynamic p_Procs,OM_CHECK=0,OM_TRACK=0,random=1395316838
	CC= gcc -g -O2 -pipe -DNDEBUG -DOM_NDEBUG -Dx86_64_Linux -DHAVE_CONFIG_H,
	CXX= g++ -O2 -w -fomit-frame-pointer -fno-rtti -I.. -I/users/cip/alggeom/hannes/wawa64 -pipe -DNDEBUG -DOM_NDEBUG -Dx86_64_Linux -DHAVE_CONFIG_H (4.7.3)
argv[0]   :	Singular-n
SearchPath:	/users/cip/alggeom/hannes/wawa64/x86_64-Linux/MOD:/users/cip/alggeom/hannes/wawa64/LIB
Singular  :	/users/cip/alggeom/hannes/wawa64/x86_64-Linux/Singular-3-1-7
BinDir    :	/users/cip/alggeom/hannes/wawa64/x86_64-Linux
RootDir   :	/users/cip/alggeom/hannes/wawa64
DefaultDir:	/users/cip/alggeom/hannes/wawa64
InfoFile  :	
IdxFile   :	
HtmlDir   :	
ManualUrl :	http://www.singular.uni-kl.de/Manual/3-1-7
ExDir     :	
Path      :	/users/cip/alggeom/hannes/wawa64/x86_64-Linux:/users/cip/alggeom/steenpas/.bin:/usr/local/bin:/usr/bin:/bin:/usr/x86_64-pc-linux-gnu/gcc-bin/4.6.3
EmacsDir  :	/users/cip/alggeom/hannes/wawa64/emacs
Available HelpBrowsers: dummy, emacs, 
Current HelpBrowser: dummy 
                     SINGULAR                                 /  Development
 A Computer Algebra System for Polynomial Computations       /   version 3-1-7
                                                           0<
 by: W. Decker, G.-M. Greuel, G. Pfister, H. Schoenemann     \   Aug 2013
FB Mathematik der Universitaet, D-67653 Kaiserslautern        \
// ** executing /users/cip/alggeom/hannes/wawa64/LIB/.singularrc
> ring R = 0, (x,y,z), dp;
> ideal I = xy3+514640752x2z2+892043968x2y-258797374xy2+240165685y2z-52941073x2,
. x2y2-584116467xy2z+707269337x2z2-974334032xyz2+691124772yz3+24388599x3-681670858x2z+110950945xyz-486562075y2+512160555xz+471970893z2;
> ideal J = 5xy2+58xyz+8x2+66yz+46z2;
> option(returnSB);
> ideal Q = quotient(I, J);
> attrib(Q, "isSB");
0

Change History (5)

comment:1 Changed 10 years ago by Oleksandr

Keywords: quotient isSB added

comment:2 Changed 10 years ago by Oleksandr

This is a bug since option(returnSB) means:

the functions syz, intersect, quotient, modulo return a standard base instead of a generating set if returnSB is set. This option should not be used for lift.

I confirm the bug with the latest Singular4 (SW).

comment:3 Changed 10 years ago by hannes

Resolution: fixed
Status: newclosed

comment:4 Changed 10 years ago by kroeker@…

Resolution: fixed
Status: closedreopened

I can't see a corresponding regression test,

was a test added in a later commit?

comment:5 Changed 10 years ago by hannes

Resolution: fixed
Status: reopenedclosed

considered also: syz, intersect, modulo

Note: See TracTickets for help on using tickets.