Opened 9 years ago

Closed 9 years ago

#589 closed proposed feature (not a bug)

review process: ask for adequate tests

Reported by: kroeker@… Owned by: somebody
Priority: critical Milestone: 4-1-0 and higher
Component: dontKnow Version: 4-0-0
Keywords: adequate tests review Cc:

Description

Among documentation, a new code contribution should contain adequate tests, not just a single example.

If a review is not done carefully, unreasonably number of new bugs will be added to the project. The implications are well known: the developers will have to spend more and more time for debugging.

Nobody wants this to happen.

Change History (1)

comment:1 Changed 9 years ago by hannes

Resolution: not a bug
Status: newclosed

You do not understand the different target audiences: an example show the typical use (and for not too difficult stuff), an easy one is usually enough. An test is completely different: here we want to test corner cases, the goal is a good coverage of the sources (and not the number of tests). Again different are timing examples. And only the first one belongs to documentation.

Note: See TracTickets for help on using tickets.