Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#65 closed bug (invalid)

super commutative ring with matrix order

Reported by: seelisch Owned by: Oleksandr
Priority: major Milestone: Release 3-1-0
Component: dontKnow Version:
Keywords: SCA, NC, std Cc: Simon, King, <king@…>

Description

reported by Simon King, Uni Jena:

Dear Singular-Team,

in the attachment is the definition of a super commutative ring with matrix order, together with some ideals. From theory, it is known that the ideal I is given by a two-sided Gröbner basis (and I verified it with twostd). I obtain the following very annoying bug:


FIRST RUN:

< "NCBug.sing";

...

. std(I,FRS1[1]); STDIN 2. std(I,FRS1[1]); _[1]=0+a_2_0*a_2_1+a_2_02+b_2_3*a_1_0+a_2_1*a_1_1+a_2_1*a_1_0+a_2_0*a_1_0+a_1_0*a_1_1

slimgb(I+ideal(FRS1[1]));

STDIN 3> slimgb(I+ideal(FRS1[1])); _[1]=a_1_0*a_1_1 _[2]=c_10_12 _[3]=a_2_0*a_1_0 ... _[54]=b_8_9*a_9_11+2*b_2_24*b_2_33*a_3_5+b_2_25*b_2_32*a_3_5+b_2_26*b_2_3*a_3_5-b_2_26*b_2_32*a_1_1+b_2_27*a_3_5+b_2_27*b_2_3*a_1_1

slimgb(I+ideal(FRS1[1]));

same result

slimgb(I+ideal(FRS1[1]));

STDIN 5> slimgb(I+ideal(FRS1[1])); Singular : signal 11 (v: 3044/2009020310): Segment fault/Bus error occurred at 92b470 because of 10286 (r:0) please inform the authors trying to restart...


SECOND RUN:

< "NCBug.sing";

...

. std(I,FRS1[1]); STDIN 2. std(I,FRS1[1]); _[1]=0+a_2_0*a_2_1+a_2_02+b_2_3*a_1_0+a_2_1*a_1_1+a_2_1*a_1_0+a_2_0*a_1_0+a_1_0*a_1_1

std(I+ideal(FRS1[1]));

STDIN 3> std(I+ideal(FRS1[1])); _[1]=a_1_0*a_1_1 _[2]=a_2_0*a_1_0 _[3]=a_2_1*a_1_0-a_2_0*a_1_1 _[4]=a_2_1*a_1_1 _[5]=b_2_3*a_1_0-b_2_2*a_1_1 _[54]=b_8_9*a_9_11+2*b_2_24*b_2_33*a_3_5+b_2_25*b_2_32*a_3_5+b_2_26*b_2_3*a_3_5-b_2_26*b_2_32*a_1_1+b_2_27*a_3_5+b_2_27*b_2_3*a_1_1

NF(c_10_12,_);

STDIN 4> NF(c_10_12,_); 0

std(I+ideal(FRS1[1]));

STDIN 5> std(I+ideal(FRS1[1])); Singular : signal 11 (v: 3044/2009020310): Segment fault/Bus error occurred at 7ffffffffffffeff because of 10206 (r:0) please inform the authors trying to restart...


So, the summary is:

  • std(id, f) yields a very strange polynomial: The first monomial is printed as "0"!
  • std(id, f) and std(id+ideal(f)) yield widely different results.
  • applying std(id+ideal(f)) twice or slimgb(id+ideal(f)) three times yields a segmentation fault.

Since I have no trac account, perhaps one of you can open tickets.

I encountered (and reported) similar bugs various times and, so far, always found work arounds. But if neither std(id, poly) nor std(id+ideal(poly)) nor slimgb(id+ideal(poly)) work reliably, I really don't know what else I could do!

I would appreciate any hint for a work around.

Best regards,

Simon

I use the Singular version that is shipped with Sage:

Singular for x86_64-Linux version 3-0-4 (3044-2009020310) Feb 3 2009 10:03:54 with

factory(@(#) factoryVersion = 3.0.4),libfac(3.0.4,Mar 2008), GMP(4.2),NTL(5.4.2),static readline,Plural,DBM, namespaces,dynamic modules,dynamic

p_Procs,OM_CHECK=0,OM_TRACK=0,random=1233652259

CC= gcc -O3 -g -fPIC -pipe -DNDEBUG -DOM_NDEBUG -Dx86_64_Linux

-DHAVE_CONFIG_H,

CXX= g++ -O3 -g -fPIC -pipe -DNDEBUG -DOM_NDEBUG -Dx86_64_Linux

-DHAVE_CONFIG_H (4.2.1) argv[0] : Singular-3-0-4 SearchPath?: /home/king/SAGE/devel/sage-3.2.1/local/LIB Singular : /home/king/SAGE/devel/sage-3.2.1/local/bin/Singular-3-0-4 BinDir? : /home/king/SAGE/devel/sage-3.2.1/local/bin RootDir? : /home/king/SAGE/devel/sage-3.2.1/local DefaultDir?: /home/king/SAGE/devel/sage-3.2.1/local InfoFile? : IdxFile? : HtmlDir? : ManualUrl? : http://www.singular.uni-kl.de/Manual/3-0-4 ExDir? : Path : /home/king/SAGE/devel/sage-3.2.1/local/bin:/home/king/SAGE/devel/sage-3.2.1:/home/king/bin:/usr/local/bin:/usr/bin:/usr/X11R6/bin:/bin:/usr/games:/opt/gnome/bin:/opt/kde3/bin:/opt/cross/bin:/home/king/Projekte/Cohom/CAS/present/bin:/home/king/Projekte/Meataxe/OLD/mtx2.2.3/bin/mpc739 EmacsDir? : Available HelpBrowsers?: dummy, emacs, Current HelpBrowser?: dummy

SINGULAR / Development

A Computer Algebra System for Polynomial Computations / version 3-0-4

0<

by: G.-M. Greuel, G. Pfister, H. Schoenemann \ Nov 2007

FB Mathematik der Universitaet, D-67653 Kaiserslautern \

Attachments (3)

NCBug.tst (4.3 KB) - added by Oleksandr 14 years ago.
tst
NCBug.res (15.1 KB) - added by Oleksandr 14 years ago.
res for current (more or less) Singular
SingularVersionDate (2.2 KB) - added by Oleksandr 14 years ago.
my Singular fingertips

Download all attachments as: .zip

Change History (8)

comment:1 Changed 14 years ago by Oleksandr

Owner: changed from hannes to Oleksandr

Changed 14 years ago by Oleksandr

Attachment: NCBug.tst added

tst

Changed 14 years ago by Oleksandr

Attachment: NCBug.res added

res for current (more or less) Singular

comment:2 Changed 14 years ago by Oleksandr

Cc: Simon King <king@…> added
Keywords: SCA NC std added
Resolution: invalid
Status: newclosed

as far as i can see, this was fixed a long time ago!

Simon, please DO try using cvs version of Singular before submitting bug!!!!!!!!!

Changed 14 years ago by Oleksandr

Attachment: SingularVersionDate added

my Singular fingertips

comment:3 in reply to:  2 Changed 14 years ago by anonymous

Replying to motsak:

as far as i can see, this was fixed a long time ago!

The Singular version available at http://www.singular.uni-kl.de/ dates of November 2007. As far as I know, this is the same version that I was using.

So, if the bug is not fixed in the published version, I would not agree that it was fixed a long time ago. After all, I am arguing from a user point of view.

comment:4 Changed 14 years ago by Oleksandr

In this case, I cannot imagine any possible reason to expect the bug already(!) reported (by You) in the middle 2008 to be fixed in late November 2007' release.

Moreover, users (without cvs access, unlike You) may use our ftp via http://www.mathematik.uni-kl.de/ftp/pub/Math/Singular/UNIX/ for instance there are several bug-fixes (say, Singular-3-0-4-4-ix86-Linux-static.tar.gz)

Anyway, thank you for using/testing one of the most recent (still under development) features of Singular!

It seems that I was wrong in my assumption that you might want to work with the most known-bug-free version of Singular and can use our cvs to get it... Probably this is the reason why you have never confirmed this bug to be fixed (i remember asking you for feedback)...

I am sorry if i was kinda harsh but i hope you can understand me now.

comment:5 Changed 14 years ago by seelisch

Milestone: Release 3-1-0
Note: See TracTickets for help on using tickets.