Opened 10 years ago

Closed 10 years ago

#657 closed bug (fixed)

char_series: can't compute multiplicative inverse error

Reported by: kroeker@… Owned by: Oleksandr
Priority: minor Milestone: 4-1-0 and higher
Component: factory Version: 4-0-1
Keywords: char_series multiplicative inverse bug Cc:

Description

failing example:

ring rng =(7),(a,x,y,z,w),dp;

ideal PS = 
-2*a*y*z^2-2*y*z^2+2*a*z-3*z-1,
-2*x*w^2-3*a*x+x,
-a*y^3+y^3+2*a-2,
a^2+a+3;

char_series(PS);

output:

zz_pX InvMod: can't compute multiplicative inverse
Singular : signal 6 (v: 4010):
current line:>>char_series(PS);<<
Segment fault/Bus error occurred at 1591990 because of 206 (r:1413880267)

Change History (3)

comment:2 Changed 10 years ago by Oleksandr

Owner: changed from somebody to Oleksandr

comment:3 Changed 10 years ago by hannes

Resolution: fixed
Status: newclosed

cannot reproduce it in the standard configuration (with flint 2.4.4, ntl 5.5.2), but the patch ​https://github.com/Singular/Sources/pull/658 seems to work.

Note: See TracTickets for help on using tickets.