Opened 8 years ago

Closed 8 years ago

#681 closed proposed feature (not a bug)

all merged commits should have passed a review

Reported by: kroeker@… Owned by: somebody
Priority: blocker Milestone: 4-1-0 and higher
Component: dontKnow Version: 4-0-1
Keywords: Cc:

Description

In recent commits (related to 'primdec::prepareQuotientring') new obvious bugs were added again. I suspect that the contributions were not reviewed and nobody is perfect.

For my taste new bugs are added too often and the new bug rate could be reduced by rigorous code review.

Therefore I suggest that all contributions (with no exception!) should pass a code review before they are merged. Please discuss this enhancement and its implementation on the next Singular meeting.

Jakob

Change History (1)

comment:1 Changed 8 years ago by Oleksandr

Resolution: not a bug
Status: newclosed

thanks for your suggestions

Note: See TracTickets for help on using tickets.