Opened 7 years ago

Closed 7 years ago

#740 closed bug (not a bug)

Location of help.cnf

Reported by: Simon King Owned by: somebody
Priority: minor Milestone: 3-1-6 and higher
Component: dontKnow Version: 3-1-7
Keywords: help.cnf Cc:

Description (last modified by Simon King)

The following was found in Singular version 3-1-7 while working at some Sage ticket.


> system("--version");
   ? cannot open `help.cnf`
Singular for x86_64-Linux version 3-1-7 (3170)  Aug 22 2015 12:22:22
with
        factory(@(#) factoryVersion = 3.1.7),libfac(3.1.7,December 2013),
        GMP(5.1),NTL(9.3.0),FLINT(2.5.2),64bit,static readline,Plural,DBM,
        dynamic modules,dynamic p_Procs,OM_CHECK=0,OM_TRACK=0,random=1441887057
        CC= gcc -O2 -g -fPIC -pipe -DNDEBUG -DOM_NDEBUG -Dx86_64_Linux -DHAVE_CONFIG_H,
        CXX= g++ -O2 -g -fPIC -I.. -I/home/king/Sage/git/sage/local -pipe -DNDEBUG -DOM_NDEBUG -Dx86_64_Linux -DHAVE_CONFIG_H (4.8.3 20140627 [gcc-4_8-branch revision 212064])
argv[0]   :     singular
SearchPath:     /home/king/Sage/git/sage/local/share/singular
Singular  :     /home/king/Sage/git/sage/local/bin/Singular
BinDir    :     /home/king/Sage/git/sage/local/bin
RootDir   :     /home/king/Sage/git/sage/local
DefaultDir:     /home/king/Sage/git/sage/local
InfoFile  :
IdxFile   :
HtmlDir   :
ManualUrl :     http://www.singular.uni-kl.de/Manual/3-1-7
ExDir     :
Path      :     /home/king/Sage/git/sage/local/bin:/home/king/Sage/git/sage/local/libexec/ccache:/home/king/Sage/git/sage/build/bin:/home/king/Sage/git/sage/src/bin:/home/king/bin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/games:/usr/lib/qt3/bin
EmacsDir  :
Available HelpBrowsers: dummy, emacs, 
Current HelpBrowser: dummy 
   ? error occurred in or before STDIN line 1: `system("--version");`

So, there is an error raised. However, when REPEATING the same command, it works fine.

There actually is $SAGE_LOCAL/share/singular/LIB/help.cnf, which is the directory used for the singular library. We found that the error disappears when creating an empty file (or copying the existing help.cnf) at $SAGE_LOCAL/share/singular/help.cnf

Change History (4)

comment:1 Changed 7 years ago by Simon King

Is the current file location $SAGE_LOCAL/share/singular/LIB/help.cnf correct? Then I guess the above error is an upstream bug. Or should the file rather be in the second location? Then the bug is in Sage.

What would you recommend to do to work around the problem?

comment:2 Changed 7 years ago by Simon King

Description: modified (diff)

comment:3 Changed 7 years ago by Simon King

I stand corrected concerning the file location. There used to be a file $SAGE_LOCAL/share/singular/LIB/help.cnf in old versions of Sage. But now it is gone. In other words: Please tell us where we shall install help.cnf!

comment:4 Changed 7 years ago by hannes

Resolution: not a bug
Status: newclosed

help.cnf should be located at the same place as the singular libraries, i.e. at /home/king/Sage/git/sage/local/share/singular/help.cnf in the example above. (The possible locations are defined in kernel/feResource.cc, the currently valid search path (after evalutation all possible locations and enviroment variables) is displayed as SearchPath? by Singular -v)

Note: See TracTickets for help on using tickets.