Opened 5 years ago

Closed 5 years ago

#825 closed bug (not a bug)

groebner basis bug

Reported by: ravenschade@… Owned by: somebody
Priority: critical Milestone: 4-2-0 and higher
Component: dontKnow Version: 4-1-0
Keywords: groebner, std Cc:

Description

The program gist.github.com/ravenschade/3eb48956a715c147c52228c370e9f1cd (sorry for external link but trac breaks formating) gives the result: sj[1]=(1.000e+00)

That means std() finds that 1 belongs to the ideal, which means that the polynomial system has no solution.

But there is at least one solution of this polynomial system: phir_1_1=1/sqrt(2) phir_1_3=1/sqrt(2) phir_2_2=1/sqrt(2) phir_2_4=1/sqrt(2) x1a=-3.75 x2a=-3 all others equal to 0.

tested on Singular for x86_64-Linux version 4.1.1 (4110, 64 bit) Feb 2018, same happens on www.singular.uni-kl.de:8003/

Change History (1)

comment:1 Changed 5 years ago by hannes

Resolution: not a bug
Status: newclosed

Groebner basis computations over ring with inexact coefficients cannot be trusted due to rounding errors. Change "real" in your ring construction to QQ:

ring r=QQ,(x1a,x2a,phir_1_1,phir_1_2,phii_1_2,phir_1_3,phii_1_3,phir_1_4,phii_1_4,phir_2_1,phir_2_2,phii_2_2,phir_2_3,phii_2_3,phir_2_4,phii_2_4),dp;

(and use "slimgb" instead of "std", it is faster with this example).

Added warnings, see ad3f9d3251be478eb821609173621d0466a50772

Note: See TracTickets for help on using tickets.