Opened 3 years ago

Closed 3 years ago

#857 closed bug (fixed)

issues with polymake.lib/follow to ticket #854

Reported by: anonymous Owned by: somebody
Priority: minor Milestone: 4-2-0 and higher
Component: dontKnow Version: 4-1-2
Keywords: Cc:


I tried to use polymake.lib and when performing the command

LIB "polymake.lib;

I get the following error suggesting that is not loaded. My operating system is macOS Sierra.

loaded /Applications/Singular?.app/Contents/bin/../libexec/singular/MOD/ for a different version of Singular(expected MAX_TOK: 537, got 533)

? dynl_open failed:dlopen(/Applications/, 10): Library not loaded: /Users/hannes/t/lib/libgfan.0.dylib

Referenced from: /Applications/Singular?.app/Contents/libexec/singular/MOD/ Reason: image not found

? not found ? error occurred in or before polymake.lib::mod_init line 137: LIB ""; ? leaving polymake.lib::mod_init

Change History (2)

comment:1 Changed 3 years ago by ren

I've just tried to install Singular on my laptop using the .dmg file and there indeed seems to be something wrong with the installer.

Just to be sure: is this also how you installed Singular on your machine?

comment:2 Changed 3 years ago by hannes

Resolution: fixed
Status: newclosed

The .dmg file was recreated, it should be fixed now (see #854).

Note: See TracTickets for help on using tickets.